Simple Mining - S2 - Power Outage – Incident details
Report an issue
Get updates
Email
Slack
Discord
Google Chat
API
Report an issue
Get updates
All systems operational
S2 - Power Outage
Resolved
Operational
Started 11 months ago
Lasted 1 day
Affected
Site #2
Major outage from 3:00 PM to 3:00 PM
Updates
Resolved
March 20, 2025 at 3:00 PM
Resolved
March 20, 2025 at 3:00 PM
This incident has been resolved.
Investigating
March 19, 2025 at 3:00 PM
Investigating
March 19, 2025 at 3:00 PM
We are currently investigating this incident.