Scheduled Curtailment -- Site 1b
Scheduled for February 13, 2026 at 2:35 PM – 3:35 PM
Affects
Site #1 B
Under maintenance from 2:35 PM to 3:35 PM
Planned
February 13, 2026 at 4:31 PMPlanned
February 13, 2026 at 4:31 PMWe will be performing scheduled maintenance at Site 1b during the time listed below. Expect miners at this site to be offline during this curtailment.
Completed
February 13, 2026 at 3:35 PMCompleted
February 13, 2026 at 3:35 PMMaintenance has completed successfully
In progress
February 13, 2026 at 2:35 PMIn progress
February 13, 2026 at 2:35 PMMaintenance is now in progress.